Skeetendo

’Cause all games were better on the GBC

You are not logged in.

#1 2016-06-30 16:45:15

mariosmentor
New member
Registered: 2016-06-30
Post 1/2

Help installing pokered?

I tried installing Cygwin, everything worked at first, but when I tried using easy_install, I got this:

bash: easy_install: command not found

So, I tried using curl, and I got this:

OSError: [Errno 11] Resource temporarily unavailable

What am I supposed to do now? Is my computer the problem? Cause all I can use is a college computer that runs Windows 7. Any advice would be appreciated.

Offline

#2 2016-06-30 19:35:46

Danny-E 33
Administrator
Registered: 2012-06-09
Post 958/1,045

Re: Help installing pokered?

Have you checked out the most recent updates to INSTALL.md?
It looks like you don't have to use easy_install or pip to install pypng.

From INSTALL.md:

To build on Windows, use Cygwin. Use the default settings.

In the installer, select the following packages: make git python gettext

Then get the most recent version of rgbds. Extract the archive and put rgbasm.exe, rgblink.exe and rgbfix.exe in C:\cygwin\usr\local\bin.

In the Cygwin terminal:

git clone --recursive https://github.com/pret/pokered
cd pokered

make

Red Hack: Pokémon Prototype

Total number of registered users: 8000+
Total number of active users: ~12

Offline

#3 2016-06-30 20:17:11

mariosmentor
New member
Registered: 2016-06-30
Post 2/2

Re: Help installing pokered?

I tried it just now. I got Pokered's files, but when I typed in make, I got this:

make: fork: Resource temporarily unavailable

What now?

Offline

#4 2016-07-05 02:05:50

Montblanc
Member
Registered: 2016-02-23
Post 27/55

Re: Help installing pokered?

Open Cygwin and write: python -V

It should give you something like this:

Python 2.7.10



Then instead of:

easy_install



Use:

easy_install-x.y



Replacing x and y for the first two version numbers, like this:

easy_install-2.7



Edit: You are typing "make" or "make red"?

Last edited by Montblanc (2016-07-05 02:07:29)

Offline

#5 2016-07-06 15:23:11

comet
Member
Registered: 2012-04-09
Post 650/679

Re: Help installing pokered?

you do not need easy_install

that error is just cygwin acting up, if you run it again it should work

Offline

Board footer

Powered by FluxBB